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Creating Pivot Tables
Pivot table is the name given to a special type of data summary table that you can 
use to analyze and reveal the relationships inherent in the data lists that you 
maintain in Excel. Pivot tables are great for summarizing particular values in a 
data list or database because they do their magic without making you create for-
mulas to perform the calculations. Unlike the Subtotals feature, which is another 
summarizing feature (see Book 6, Chapter 1 for more information), pivot tables let 
you play around with the arrangement of the summarized data — even after you 
generate the table. (The Subtotals feature only lets you hide and display different 
levels of totals in the list.) This capability to change the arrangement of the sum-
marized data by rotating row and column headings gives the pivot table its name.

Pivot tables are also versatile because they enable you to summarize data by using 
a variety of summary functions (although totals created with the SUM function 
will probably remain your old standby). You can also use pivot tables to cross-
tabulate one set of data in your data list with another. For example, you can use 
this feature to create a pivot table from an employee database that totals the sala-
ries for each job category cross-tabulated (arranged) by department or job site. 
Moreover, Excel 2019 makes it easy to create pivot tables that summarize data 
from more than one related data list entered in the worksheet or retrieved from 
external data in what’s known as a Data Model. (See Book 6, Chapter 2 for more 
on relating data lists and retrieving external data.)

Excel 2019 offers several methods for creating new pivot tables in your worksheets:

»» Quick Analysis tool: With all the cells in the data list selected, click the Quick 
Analysis tool and then select your pivot table on the Tables tab of its drop-
down palette.

»» Recommended PivotTables button: With the cell pointer in one of the cells 
of a data list, click the Recommended PivotTables button on the Insert tab and 
then select your pivot table in the Recommended PivotTables dialog box.

»» PivotTable button: With the cell pointer in one of the cells of a data list, click 
the PivotTable button on the Insert tab and then use the Create PivotTable 
dialog box to specify the contents and location of your new table before you 
manually select the fields in the data source to use.

Pivot tables with the Quick Analysis tool
Excel 2019 makes it simple to create a new pivot table using a data list selected in 
your worksheet with its new Quick Analysis tool. To preview various types of pivot 
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tables that Excel can create for you on the spot using the entries in a data list that 
you have open in an Excel worksheet, simply follow these steps:

1.	 Select all the data (including the column headings) in your data list as a 
cell range in the worksheet.

If you’ve assigned a range name to the data list, you can select the column 
headings and all the data records in one operation simply by choosing the 
data list’s name from the Name box drop-down menu.

2.	 Click the Quick Analysis tool that appears right below the lower-right 
corner of the current cell selection.

Doing this opens the palette of Quick Analysis options with the initial 
Formatting tab selected and its various conditional formatting options 
displayed.

3.	 Click the Tables tab at the top of the Quick Analysis options palette.

Excel selects the Tables tab and displays its Table and PivotTable option 
buttons. The Table button previews how the selected data would appear 
formatted as a table. The other PivotTable buttons preview the various types 
of pivot tables that can be created from the selected data.

4.	 To preview each pivot table that Excel 2019 can create for your data, 
highlight its PivotTable button in the Quick Analysis palette.

As you highlight each PivotTable button in the options palette, Excel’s Live 
Preview feature displays a thumbnail of a pivot table that can be created using 
your table data. This thumbnail appears above the Quick Analysis options 
palette for as long as the mouse or Touch pointer is over its corresponding 
button.

5.	 When a preview of the pivot table you want to create appears, click its 
button in the Quick Analysis options palette to create it.

Excel 2019 then creates the previewed pivot table on a new worksheet that is 
inserted at the beginning of the current workbook. This new worksheet 
containing the pivot table is active so that you can immediately rename and 
relocate the sheet as well as edit the new pivot table, if you wish.

Figures  2-1 and  2-2 show you how this procedure works. In Figure  2-1, I’ve 
highlighted the fourth suggested PivotTable button in the Quick Analysis tool’s 
option palette. The previewed table in the thumbnail displayed above the palette 
shows the salaries subtotals and grand totals in the Employee Data list organized 
whether or not the employees participate in profit sharing (Yes or No).
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FIGURE 2-1:  
Previewing 

the pivot table 
created from the 

selected data 
in the Quick 

Analysis options 
palette.

FIGURE 2-2:  
Previewed pivot 
table created on 

a new worksheet 
with the Quick 

Analysis tool.
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Figure 2-2 shows you the pivot table that Excel created when I clicked the high-
lighted button in the options palette in Figure 2-1. Note this pivot table is selected 
on its own worksheet (Sheet1) that’s been inserted in front of the Employee Data 
worksheet. Because the new pivot table is selected, the PivotTable Fields task pane 
is displayed on the right side of the Excel worksheet window and the PivotTable 
Tools context tab is displayed on the Ribbon. You can use the options on this task 
pane and contextual tab to then customize your new pivot table as described in the 
“Formatting a Pivot Table” section later in this chapter.

Note that if Excel can’t suggest various pivot tables to create from the selected 
data in the worksheet, a single Blank PivotTable button is displayed after the 
Table button in the Quick Analysis tool’s options on the Tables tab. You can select 
this button to manually create a new pivot table for the data as described later in 
this chapter.

Recommended pivot tables
If creating a new pivot table with the Quick Analysis tool (described in the previ-
ous section) is too much work for you, you can quickly generate a pivot table with 
the new Recommended Pivot Tables command button. To use this method, follow 
these three easy steps:

1.	 Select a cell in the data list for which you want to create the new pivot 
table.

Provided that the data list has a row of column headings with contiguous rows 
of data as described in Book 6, Chapter 1, this can be any cell in the table.

2.	 Click the Recommended PivotTables command button on Insert tab of 
the Ribbon or press Alt+NSP.

Excel displays a Recommended PivotTables dialog box similar to the one 
shown in Figure 2-3. This dialog box contains a list box on the left side that 
shows samples of all the suggested pivot tables that Excel 2019 can create 
from the data in your list.

3.	 Select the sample of the pivot table you want to create in the list box on 
the left and then click OK.

As soon as you click OK, Excel creates a new pivot table following the selected 
sample on its own worksheet inserted in front of the others in your workbook. 
This pivot table is selected on the new sheet so that the Pivot Table Fields task 
pane is displayed on the right side of the Excel worksheet window and the Pivot-
Table Tools contextual tab is displayed on the Ribbon. You can use the options 
on this task pane and contextual tab to then customize your new pivot table as 
described in the “Formatting a Pivot Table” section later in this chapter.
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Manually created pivot tables
Creating pivot tables with the Quick Analysis tool or the Recommended Pivot-
Tables button on the Insert tab is fine provided that you’re only summarizing the 
data stored in a single data list that’s stored in your Excel worksheet.

When you want your pivot table to work with data from fields in more than 
one (related) data table or with data stored in a data table that doesn’t reside in 
your worksheet as when connecting with an external data source (see Book 6, 
Chapter 2), you need to manually create the pivot table.

Creating a pivot table with local data
To manually create a new pivot table using a data list stored in your Excel work-
book, simply open the worksheet that contains that list (see Book 6, Chapter 1) you 
want summarized by the pivot table, position the cell pointer somewhere in the 
cells of this list, and then click the PivotTable command button on the Ribbon’s 
Insert tab or press Alt+NVT.

Excel then selects all the data in the list indicated by a marquee around the cell 
range before it opens a Create PivotTable dialog box similar to the one shown in 
Figure 2-4, where the Select a Table or Range option is selected. You can then 
adjust the cell range in the Table/Range text box under the Select a Table or Range 
option button if the marquee does not include all the data to be summarized in 
the pivot table.

FIGURE 2-3:  
Creating a new 

pivot table from 
the sample 
pivot tables 

displayed in the 
Recommended 

PivotTables 
dialog box.
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By default, Excel builds the new pivot table on a new worksheet it adds to the 
workbook. If you want the pivot table to appear on the same worksheet, select the 
Existing Worksheet option button and then indicate the location of the first cell of 
the new table in the Location text box. (Just be sure that this new pivot table isn’t 
going to overlap any existing tables of data.)

If the list you’ve selected in the Table/Range text box is related to another data list 
in your workbook and you want to be able to analyze and summarize data from 
both, be sure to select the Add This Data to the Data Model check box at the bottom 
of the Create PivotTable dialog box before you click OK. (See Book 6, Chapter 2 for 
details on creating relationships between data lists using key fields.)

Creating a pivot table from external data
If you’re creating a pivot table using external data not stored in your workbook, 
you want to locate the cell pointer in the first cell of the worksheet where you want 
the pivot table before opening the Create PivotTable dialog box by selecting the 
PivotTable button on the Insert tab.

When the cell pointer’s in a blank cell when you open the Create PivotTable dialog 
box, Excel automatically selects the Use an External Data Source option as the data 
source and the Existing Worksheet option as the location for the new pivot table. To 
specify the external data table to use, you then click the Choose Connections button 
to open the Existing Connections dialog box, where you select the name of the con-
nection you want to use before you click the Open button. (See Book 6, Chapter 2 
for information on establishing connections with external database tables.)

Excel then returns you to the Create PivotTable dialog box, where the name of the 
selected external data connection is displayed after the Connection Name head-
ing. You can then modify the location settings, if need be, before creating the new 

FIGURE 2-4:  
Indicate the 
data source 

and pivot table 
location in the 

Create PivotTable 
dialog box.



680      BOOK 7  Data Analysis

pivot table by clicking OK. Note that the Add This Data to the Data Model check box 
is automatically selected (and cannot be deselected) — the relationships between 
the data tables in the source database specified by the external data connection are 
automatically reflected in fields displayed in the Field list for the new pivot table.

Constructing the new pivot table
After you indicate the source and location for the new pivot table in the Create 
PivotTable dialog box and click its OK button, the program adds a placeholder 
graphic (with the text, “To build a report, choose fields from the PivotTable Field 
List”) indicating where the new pivot table will go in the worksheet while at the 
same time displaying a PivotTable Fields task pane on the right side of the Work-
sheet area. (See Figure 2-5.)

This PivotTable Fields task pane is divided into two areas: the Choose Fields to 
Add to Report list box with the names of all the fields in the data list you selected 
as the source of the table preceded by an empty check box at the top, and an area 
identified by the heading, Drag Fields Between Areas Below, which is divided into 
four drop zones (FILTERS, COLUMNS, ROWS, and VALUES) at the bottom.

FIGURE 2-5:  
A new pivot 

table displaying 
the blank table 

grid and the 
PivotTable Fields 

List task pane.
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To complete the new pivot table, all you have to do is assign the fields in the 
PivotTable Fields task pane to the various parts of the table. You do this by drag-
ging a field name from the Choose Fields to Add to Report list box to one of the 
four areas (or drop zones) in the Drag Fields Between Areas Below section at the 
bottom of the task pane:

»» FILTERS for the fields that enable you to page through the data summaries 
shown in the actual pivot table by filtering out sets of data — they act as the 
filters for the report. So, for example, if you designate the Year Field from a 
data list as a report filter, you can display data summaries in the pivot table 
for individual years or for all years represented in the data list. They appear 
at the top of the report above the columns and rows of the pivot table.

»» COLUMNS for the fields that determine the arrangement of data shown in 
the columns of the pivot table — their entries appear in the table’s column 
headings.

»» ROWS for the fields that determine the arrangement of data shown in the 
rows of the pivot table — their entries appear in the table’s row headings.

»» VALUES for the fields whose data are presented in the cells in the body of the 
pivot table — they are the values that are summarized in the last row and 
column of the table (totaled by default).

You can also add fields to the new pivot table simply by selecting the check box 
in front of the field name. Keep in mind when you use this method to build your 
pivot table that if Excel identifies the field as text, it automatically adds it to the 
ROWS area and when it identifies the field as numeric, the program adds it to the 
VALUES area. To remove a field from the pivot table, simply clear its check box in 
the PivotTable Fields task pane.

To better understand how you can use these various areas in a pivot table, look at 
a completed pivot table in Figure 2-6. For this pivot table, I dragged these fields 
in the employee data list to the following areas in the PivotTable Fields task pane:

»» Gender field contains F (for female) or M (for male) to indicate the employee’s 
gender — to the FILTERS area.

»» Location field contains the names of the various cities with corporate 
offices — to the COLUMNS area.

»» Dept field contains the names of the various departments in the company —  
to the ROWS area.

»» Salary field contains the annual salary for each employee — to the VALUES area.
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As a result, this pivot table now displays the sum of the salaries for both the men 
and women employees in each location (across the columns) and then presents 
these sums by their department (in each row).

As soon as you create a new pivot table (or select the cell of an existing table in a 
worksheet), Excel selects the Analyze tab of the PivotTable Tools contextual tab 
added to the end of the Ribbon. Among the many groups on this tab, you find the 
Active Field group, which contains the following useful command buttons:

»» Active Field text box indicating the pivot table field that is active in 
the worksheet

»» Field Settings button to open the Field Settings dialog box, where you can 
change various settings for the pivot table field that’s active in the worksheet

»» Drill Down and Drill Up buttons to display lower levels with detail data (Drill 
Down) or higher levels with summary data (Drill Up) in a chart or matrix

»» Expand Field and Collapse Field buttons to hide and redisplay the expand (+) 
and collapse (–) buttons in front of particular Column Fields or Row Fields that 
enable you to temporarily remove and then redisplay their particular summa-
rized values in the pivot table

FIGURE 2-6:  
A completed 

pivot table after 
adding the 

fields from the 
employee data 

list to its various 
sections.
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Formatting a Pivot Table
Excel 2019 makes formatting a new pivot table you’ve added to a worksheet as 
quick and easy as formatting any other table of data or list of data. All you need to 
do is click a cell of the pivot table to add the PivotTable Tools contextual tab to the 
end of the Ribbon and then click its Design tab to display its command buttons.

The Design tab on the PivotTable Tools contextual tab is divided into three groups:

»» Layout group to add subtotals and grand totals to the pivot table and modify 
its basic layout

»» PivotTable Style Options group to refine the pivot table style you select for 
the table using the PivotTable Styles gallery to the immediate right

»» PivotTable Styles group containing the gallery of styles you can apply to the 
active pivot table by clicking the desired style thumbnail

CHANGING THE PIVOTTABLE FIELDS 
TASK PANE DISPLAY
By default, Excel displays the list of fields stacked on top of the four areas — FILTERS, 
COLUMNS, ROWS, and VALUES — in the PivotTable Fields task pane. You can change 
this arrangement by clicking the Tools drop-down button (to the immediate right of the 
Choose Fields to Add to Report heading) and then choosing one of the following options 
from its drop-down menu: Fields Section and Areas Section Side-by-Side to place the 
list of fields in a column to the left of the four areas, Fields Section Only to list only the 
fields, Areas Section Zones Only (2 by 2) to list only the areas in two columns, or Areas 
Section Zones Only (1 by 4) to list only the areas in one column.

When you display only the four areas in the PivotTable Fields task pane, you can click 
the drop-down buttons that appear to the right of the name of each field you add to 
the four areas to manipulate the fields: Move to Report Filter to move the field to the 
FILTERS area, Move to Row Labels to move the field to the ROWS area, Move to Column 
Labels to move the field to the COLUMNS area, Move to Values to move the field to 
the VALUES area, Remove Field to remove the field from its current drop zone, or Field 
Settings to open the Fields Settings dialog box, where you can adjust the subtotals, filter, 
layout, and print settings for the field.
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Refining the pivot table layout and style
After selecting a style from the PivotTable Styles gallery on the Design tab on the 
PivotTable Tools contextual tab, you can then refine the style using the command 
buttons in the Layout group and the check boxes in the PivotTable Style Options 
group.

The Layout group on the Design tab contains the following four command buttons:

»» Subtotals to hide the display of subtotals in the summary report or have 
them displayed at the top or bottom of their groups in the report

»» Grand Totals to turn on or off the display of grand totals in the last row or 
column of the report

»» Report Layout to modify the display of the report by selecting between the 
default Compact Form and the much more spread-out Outline Form (which 
connects the subtotals across the columns of the table with lines or shading 
depending on the table style selected) and Tabular Form (which connects the 
row items in the first column and the subtotals across the columns of the 
table with gridlines or shading depending on the table style selected)

»» Blank Rows to insert or remove a blank row after each item in the table

The PivotTable Style Options group contains the following four check boxes:

»» Row Headers to remove and then re-add the font and color formatting from 
the row headers of the table in the first column of the table applied by the 
currently selected pivot table style

»» Column Headers to remove and then re-add the font and color formatting 
from the column headers at the top of the table applied by the currently 
selected pivot table style

»» Banded Rows to add and remove banding in the form of gridlines or shading 
(depending on the currently selected pivot table style) from the rows of the 
pivot table

»» Banded Columns to add and remove banding in the form of gridlines or 
shading (depending on the currently selected pivot table style) from the 
columns of the pivot table

Figure 2-7 shows the original pivot table created from the employee data list after 
making the following changes:

»» Adding the Years of Service field as a second row field and then closing the 
PivotTable Fields task pane
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»» Selecting the Banded Rows check box in the PivotTable Style Options group 
on the Design contextual tab

»» Choosing the Show in Outline Form option from the Report Layout command 
button’s drop-down menu in the Layout group of the Design tab

»» Choosing the Insert Blank Line after Each Item option from the Blank Rows 
command button’s drop-down menu in the Layout group of the Design tab

»» Choosing the Show All Subtotals as Bottom of Group option from the 
Subtotals command button’s drop-down menu in the Layout group of the 
Design tab

Formatting the parts of the pivot table
Even after applying a table style to your new pivot table, you may still want to 
make some individual adjustments to its formatting, such as selecting a new font, 
font size, or cell alignment for the text of the table and a new number format for 
the values in the table’s data cells.

FIGURE 2-7:  
Revised pivot 

table in the 
Outline Form with 

an extra blank 
row between 

each item in the 
pivot table.
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You can make these types of formatting changes to a pivot table by selecting the 
part of the table to which the formatting is to be applied and then selecting the 
new formatting from the appropriate command buttons in the Font, Alignment, 
and Number groups on the Home tab of the Ribbon.

Applying a new font, font size, or  
alignment to the pivot table
You can modify the text in a pivot table by selecting a new font, font size, or 
horizontal alignment. To make these formatting changes to the text in the entire 
table, select the entire table before you use the appropriate command buttons in 
the Font and/or Alignment group on the Home tab. To apply these changes only to 
the headings in the pivot table, select only its labels before using the commands 
on the Home tab. To apply these changes only to the data in the body of the pivot 
table, select only its cells.

To help you select the cells you want to format in a pivot table, use the following 
Select items on the Actions command button’s drop-down list:

1.	 Click a cell in the pivot table in the worksheet and then click the Select 
drop-down button in the Actions group on the Analyze tab under the 
PivotTable Tools contextual tab (Alt+JTW).

2.	 On the Select submenu, you can do the following:

•	 Click the Label and Values option to select the cells with the row and 
column headings and those with the values in the table.

•	 Click the Values option to select only the cells with values in the table.

•	 Click the Labels option to select only the cells with the rows and column 
headings in the table.

•	 Click the Entire PivotTable option on the Select submenu to select all the 
pivot table cells, including the Report Filter cells.

•	 Click the Enable Selection option to be able to select single rows or 
columns of the pivot table by clicking it with the mouse or Touch pointer.

You can also use the following hot keys to select all or part of your pivot table:

»» Alt+JTWA to select the label cells with the row and column headings as well as 
the data cells with the values in the body of the pivot table

»» Alt+JTWV to select only the data cells with the values in the body of the pivot 
table
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»» Alt+JTWL to select only the label cells with the row and column headings in 
the pivot table

»» Alt+JTWT to select the entire table, that is, all the cells of the pivot table 
including those with the Report Filter

You can use the Label and Values, Values, and Labels options on the Select but-
ton’s drop-down menu and their hot key equivalents only after you have selected 
the Entire Table option to select all the cells.

Use Live Preview to preview the look of a new font or font size on the Font or Font 
Size drop-down menu in the Font group on the Ribbon’s Home tab.

Applying a number format to the data cells
When you first create a pivot table, Excel does not format the data cells in the table 
that contain the values corresponding to the field or fields you add to the VALUES 
area in the PivotTable Fields task pane and the subtotals and grand totals that 
Excel adds to the table. You can, however, assign any of the Excel number formats 
to the values in the pivot table in one of two manners.

In the first method, you select the entire table (Alt+JTWT), then select only its data 
cells in the body of the pivot table (Alt+JTWV), and then apply the desired number 
format using the command buttons in the Number group of the Home tab of the 
Ribbon. For example, to format the data cells with the Accounting number format 
with no decimal places, you click the Accounting Number Format command but-
ton and then click the Decrease Decimal command button twice.

You can also apply a number format to the data cells in the body of the pivot table 
by following these steps:

1.	 Click the name of the field in the pivot table that contains the words 
“Sum of” and then click the Field Settings button in the Active Field group 
of Analyze tab to open the Summarize Values By tab of the Value Field 
Settings dialog box.

In my Employee example pivot table, this field is called Sum of Salary because 
the Salary field is summarized. Note that this field is located at the intersection 
of the Column and Row Label fields in the table.

2.	 Click the Number Format command button in the Value Field Settings 
dialog box to open the Number tab of the Format Cells dialog box.

3.	 Click the type of number format you want to assign to the values in the 
pivot table on the Category list box of the Number tab.
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4.	 (Optional) Modify any other options for the selected number format such 
as Decimal Places, Symbol, and Negative Numbers that are available for 
that format.

5.	 Click OK twice — the first time to close the Format Cells dialog box and 
the second to close the Value Field Settings dialog box.

Sorting and Filtering the Pivot Table Data
When you create a new pivot table, you’ll notice that Excel automatically adds 
AutoFilter buttons to the Report Filter field as well as the labels for the Column 
and Row fields. These AutoFilter buttons enable you to filter out all but certain 
entries in any of these fields, and in the case of the Column and Row fields, to sort 
their entries in the table.

When you add more than one Column or Row field to your pivot table, Excel adds 
collapse buttons (–) that you can use to temporarily hide subtotal values for a 
particular secondary field. After clicking a collapse button in the table, it imme-
diately becomes an expand button (+) that you can click to redisplay the subtotals 
for that one secondary field.

Filtering the report
Perhaps the most important AutoFilter buttons in a pivot table are the ones added 
to the Report Filter field(s). By selecting a particular option on the drop-down 
lists attached to one of these AutoFilter buttons, only the summary data for that 
subset you select is then displayed in the pivot table itself.

For example, in the example pivot table (refer to Figure 2-6) that uses the Gen-
der field from the employee data list as the Report Filter field, you can display 
the sum of just the men’s salaries by location and department in the body of the 
pivot table simply by clicking the Gender field’s filter button and then selecting M 
from the drop-down list before you click OK. Likewise, you can view the summary  
of the women’s salaries by selecting F from this filter button’s drop-down list. To 
later redisplay the summary of the salaries for all the employees, you then reselect 
the (All) option from this list before you click OK.

Excel then displays M in the Gender Report Filter field instead of the default (All) 
and replaces the standard drop-down button icon with a cone-shaped filter icon, 
indicating that the field is currently being filtered to show only some of the values 
in the data source.
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Filtering individual Column and Row fields
The AutoFilter buttons on the Column and Row fields enable you to filter par-
ticular groups and, in some cases, individual entries in the data source. To filter 
the summary data in the columns or rows of a pivot table, click the Column or 
Row field’s filter button and start by deselecting the check box for the (Select All) 
option at the top of the drop-down list to clear its check mark. Then, select the 
check boxes for all the groups or individual entries whose summed values you still 
want displayed in the pivot table to put check marks back in each of their check 
boxes before you click OK.

As when filtering a Report Filter field in the table, Excel replaces the standard 
drop-down button icon displayed in the particular Column or Report field with a 
cone-shaped filter icon. This icon indicates that the field is currently being fil-
tered and only some of its summary values are now displayed in the pivot table. 
To redisplay all the values for a filtered Column or Report field, you need to click 
its filter button and then select the (Select All) option at the top of its drop-down 
list before you click OK.

Figure 2-8 shows the original sample pivot table after formatting the values (with 
a number format that uses a comma as a thousands separator and displays zero 
decimal places) and then filtering its Gender Filter Report Field to women by 
selecting F (for Female) and its Dept Row Field to Accounting, Administration, 
and Human Resources.

Notice in Figure 2-8 that after filtering the pivot table by selecting F in the Gender 
Filter Report field and selecting Accounting, Administration, and Human Resources 
departments as the only Dept Row fields, the filtered pivot table no longer displays 
salary summaries for all of the company’s locations. (Santa Rosa, Seattle, and 
Atlanta locations are missing.) You can tell that the table is missing these locations 
because there are no women employees in the three selected departments and not 
as a result of filtering the Location Column Labels field because its drop-down 
button still uses the standard icon and not the cone filter icon now shown to the 
right of the Gender Filter Report and Dept Row Labels fields.

Slicing the pivot table data
Excel 2019 supports slicers, a graphic tool for filtering the data in your pivot table. 
Instead of having to filter the data using the check boxes attached to an item 
list on the drop-down menus on a field’s AutoFilter button, you can use slicers 
instead. Slicers, which float as graphic objects over the worksheet, not only enable 
you to quickly filter the data in particular fields of a pivot table, but also enable 
you to connect slicers to multiple pivot tables or to a pivot table and a pivot chart 
you’ve created.
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To use slicers on a pivot table, click one of the table’s cells and then click the Insert 
Slicer button in the Filter group of the table’s Analyze tab. Excel then displays an 
Insert Slicers dialog box containing a list of all the fields in the current pivot table. 
You then select the check boxes for all the fields you want to filter the pivot table 
for before you select OK.

Excel then displays a slicer for each field you select in the Insert Slicers dialog box. 
Each slicer appears as a rectangular graphic object that contains buttons for each 
entry in the particular pivot table field. You can then filter the data in the pivot 
table simply by clicking the individual entries in the slicer for all the values you 
still want displayed in the table. To display values for multiple, nonconsecutive 
entries in a particular field, you hold down the Ctrl key as you click entries in its 
slicer. To display values of multiple consecutive values, you click the first entry in 
its slicer and then hold the Shift key as you click the last entry you want included.

Figure 2-9 shows you the pivot table for the employee data list after I used three 
slicers to filter it. The first slicer is for the Gender field, where I selected M so that 
only the records for the men are displayed in the pivot table. The second slicer is 
for the Dept field, where I clicked the Engineering item to display only the men’s 
salaries in Engineering. The third and final slicer is for the Location field, where 
I selected the Chicago, San Francisco, and Seattle locations (by holding down the 
Ctrl key as I clicked their buttons in the Location slicer). As a result, the employee 
data pivot table is now filtered so that you see only the salary totals for the men 
in the Engineering departments at the Chicago, San Francisco, and Seattle offices.

FIGURE 2-8:  
The pivot table 

after filtering 
the Gender 

Filter Report 
field and the 

Dept Row field.
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Because slicers are graphic objects, when you add them to your worksheet, the 
program automatically adds an Options tab under a Slicer Tools contextual tab 
to the Ribbon. This Options tab contains many of the same graphic controls that 
you’re used to when dealing with standard graphic objects such as shapes and text 
boxes, including a Slicer Styles drop-down gallery and Bring Forward, Send Back, 
and Selection Pane that you can use to format the currently selected slicer. You can 
also use the Height and Width options in the Buttons and Size groups to modify 
the dimensions of the slicer and the buttons it contains. Finally, you can use the 
Report Connections command button to open the Report Connections dialog box, 
where you can connect additional pivot tables to the currently selected slicer.

To move a slicer, you click it to select it and then drag it from somewhere on its 
border using the black-cross pointer with an arrowhead. To deselect the items 
you’ve selected in a slicer, click the button in the upper-right corner of the slicer 
with a red x through the filter icon. To get rid of a slicer (and automatically redis-
play the PivotTable Fields task pane), select the slicer and then press the Delete key.

Using timeline filters
Excel 2019 also enables you to filter your data with its timeline feature. You can 
think of timelines as slicers designed specifically for date fields that enable you 
to filter data out of your pivot table that doesn’t fall within a particular period, 
thereby allowing you to see timing of trends in your data.

FIGURE 2-9:  
Employee pivot 

table showing the 
men’s salaries in 
the Engineering 

department in 
Chicago, San 

Francisco, and 
Seattle.
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To create a timeline for your pivot table, select a cell in your pivot table and then 
select the Insert Timeline button in the Filter group on the Analyze contextual tab 
under the PivotTable Tools tab on the Ribbon. Excel then displays an Insert Time-
lines dialog box displaying a list of pivot table fields that you can use in creating 
the new timeline. After selecting the check box for the date field you want to use 
in this dialog box, click OK.

Figure 2-10 shows you the timeline I created for the sample Employee Data list by 
selecting its Date Hired field in the Insert Timelines dialog box. As you can see, 
Excel created a floating Date Hired timeline with the years and months demar-
cated and a bar that indicates the time period selected. By default, the timeline 
uses months as its units, but you can change this to years, quarters, or even days 
by clicking the time units’ drop-down button immediately below the filter icon in 
the upper-right corner of the timeline and then selecting the desired time unit.

For Figure 2-10, I selected the Years option as the timeline’s unit and then selected 
the period 1995 through 1999 so that the pivot table shows the salaries by depart-
ment and location for only employees hired during this four-year period. I did this 
simply by dragging the timeline bar in the Date Hired timeline graphic so that it 
begins at 1995 and extends just up to 2000. And should I need to filter the pivot 
table salary data for other hiring periods, I would simply modify the start and stop 
times by dragging the timeline bar in the Date Hired timeline.

FIGURE 2-10:  
Employee pivot 

table using a 
timeline filter to 

show the salaries 
for employees 

hired during 
the period 1995 

through 1999.
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Sorting the pivot table
You can instantly reorder the summary values in a pivot table by sorting the table 
on one or more of its Column or Row fields. To re-sort a pivot table, click the 
AutoFilter button for the Column or Row field you want to use in the sort and then 
click either the Sort A to Z option or the Sort Z to A option at the top of the field’s 
drop-down list.

Click the Sort A to Z option when you want the table reordered by sorting the 
labels in the selected field alphabetically, or, in the case of values, from the small-
est to largest value, or, in the case of dates, from the oldest to newest date. Click 
the Sort Z to A option when you want the table reordered by sorting the labels in 
reverse alphabetical order (Z to A), values from the highest to smallest, and dates 
from the newest to oldest.

Modifying the Pivot Table
As the term pivot implies, the fun of pivot tables is being able to rotate the data 
fields by using the rows and columns of the table, as well as to change what fields 
are used on the fly. For example, suppose that after making the data list’s Loca-
tion field the pivot table’s Column Labels Field, and its Dept field the Row Labels 
Field, you now want to see what the table looks like with the Dept field as the 
Column Labels Field and the Location field as the Row Labels Field.

No problem: All you have to do is open the PivotTable Fields task pane (Alt+JTL) 
and then drag Location from the COLUMNS area to the ROWS area and then drag 
Dept from the ROWS to COLUMNS. Voilà — Excel rearranges the totaled salaries 
so that the rows of the pivot table show the location grand totals, and the columns 
now show the departmental grand totals. Figure 2-11 shows this new arrangement 
for the pivot table.

In fact, when pivoting a pivot table, not only can you rotate existing fields, but 
you can also add new fields to the pivot table or assign more fields to the table’s 
COLUMNS and ROWS areas.

Figure 2-12 illustrates this situation. This figure shows the same pivot table after 
making a couple of key changes to the table structure. First, I added the Profit 
Sharing field as a second Report Filter field by dragging it to the FILTERS area in 
the PivotTable Fields task pane. Then, I made Location a second Row Labels Field 
by dragging it from the COLUMNS area to the ROWS area. Finally, for this figure, 
I changed the setting in the Gender Report Filter from the default of All to M and 
changed the Profit Sharing Report Filter to Yes.
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FIGURE 2-11:  
Pivoting the table 

so that Dept is 
now the Column 
Labels Field and 

Location the Row 
Labels Field.

FIGURE 2-12:  
The pivot table 

after adding 
Profit Sharing as 

another Report 
Filter and making 

both the Dept 
and Location 

Row Fields.
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As a result, the modified pivot table shown in Figure 2-12 now shows the salary 
totals for all the men in the corporation arranged first by their department and 
then by their location. Because I added Profit Sharing as a second Report Filter, I 
can see the totals for just the men or just the women who are or aren’t currently 
enrolled in the profit sharing plan simply by selecting the appropriate Report Fil-
ter settings.

Changing the summary functions
By default, Excel uses the good old SUM function to total the values in the numeric 
field(s) that you add to the VALUES area, thereby assigning them to the data cells 
in the body of the pivot table. Some data summaries require the use of another 
summary function, such as the AVERAGE or COUNT function.

To change the summary function that Excel uses, you open the Field Settings 
dialog box for one of the fields that you use as the data items in the pivot table. 
You can do this either by clicking the Value Field Settings option on the field’s 
drop-down menu in the VALUES area in the PivotTable Fields task pane (Alt+JTL) 
or by right-clicking the field’s label and then selecting Value Field Settings on its 
shortcut menu.

After you open the Value Field Settings dialog box for the field, you can change 
its summary function from the default Sum to any of the following functions by 
selecting it on the Summarize By tab:

»» Count to show the count of the records for a particular category (note that 
COUNT is the default setting for any text fields that you use as Data Items in 
a pivot table)

»» Average to calculate the average (that is, the arithmetic mean) for the values 
in the field for the current category and page filter

»» Max to display the largest numeric value in that field for the current category 
and page filter

»» Min to display the smallest numeric value in that field for the current category 
and page filter

»» Product to display the product of the numeric values in that field for the 
current category and page filter (all nonnumeric entries are ignored)

»» Count Numbers to display the number of numeric values in that field for the 
current category and page filter (all nonnumeric entries are ignored)

»» StdDev to display the standard deviation for the sample in that field for the 
current category and page filter
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»» StdDevp to display the standard deviation for the population in that field for 
the current category and page filter

»» Var to display the variance for the sample in that field for the current category 
and page filter

»» Varp to display the variance for the population in that field for the current 
category and page filter

After you select the new summary function to use on the Summarize By tab of the 
Value Field Settings dialog box, click the OK button to have Excel apply the new 
function to the data presented in the body of the pivot table.

Adding Calculated Fields
In addition to using various summary functions on the data presented in your pivot 
table, you can create your own Calculated Fields for the pivot table. Calculated Fields 
are computed by a formula that you create by using existing numeric fields in the 
data source. To create a Calculated Field for your pivot table, follow these steps:

1.	 Click any of the cells in the pivot table and then select the Calculated 
Field option from the Fields, Items, & Sets button’s drop-down list on the 
Analyze tab or press Alt+JTJF.

The Fields, Items, & Sets command button is found in the Calculations group 
on Analyze tab on the PivotTable Tools contextual tab.

Excel opens the Insert Calculated Field dialog box similar to the one shown in 
Figure 2-13.

2.	 Enter the name for the new field in the Name text box.

Next, you create the formula in the Formula text box by using one or more of 
the existing fields displayed in the Fields list box.

3.	 Click the Formula text box and then delete the zero (0) after the equal 
sign and position the insertion point immediately following the equal 
sign (=).

Now you’re ready to type in the formula that performs the calculation. To do 
this, insert numeric fields from the Fields list box and indicate the operation to 
perform on them with the appropriate arithmetic operators (+, -, *, or /).

4.	 Enter the formula to perform the new field’s calculation in the Formula 
text box, inserting whatever fields you need by clicking the name in the 
Fields list box and then clicking the Insert Field button.
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For example, in Figure 2-13, I created a formula for the new calculated field 
called Bonus that multiplies the values in the Salary Field by 2.5 percent (0.025) 
to compute the total amount of annual bonuses to be paid. To do this, I 
selected the Salary field in the Fields list box and then clicked the Insert Field 
button to add Salary to the formula in the Formula text box (as in =Salary). 
Then, I typed *0.025 to complete the formula (=Salary*0.025).

When you finish entering the formula for your calculated field, you can add the 
calculated field to the PivotTable Fields task pane by clicking the Add button. 
After you click the Add button, it changes to a grayed-out Modify button. If you 
start editing the formula in the Formula text box, the Modify button becomes 
active so that you can click it to update the definition.

5.	 Click OK in the Insert Calculated Field dialog box.

This action closes the Insert Calculated Field dialog box and adds the summary 
of the data in the calculated field to your pivot table.

After you finish defining a calculated field to a pivot table, Excel automatically 
adds its name to the field list in the PivotTable Fields task pane and to the VALUES 
area thereby assigning the calculated field as another Data item in the body of the 
pivot table.

If you want to temporarily hide a calculated field from the body of the pivot table, 
click the name of the calculated field in the field list in the PivotTable Fields task 
pane (Alt+JTL) to remove the check mark from its check box in the field list. Then, 
when you’re ready to redisplay the calculated field, you can do so by clicking its 
check box in the field list in the PivotTable Fields task pane again to put a check 
mark back into it.

FIGURE 2-13:  
Creating a 

calculated field 
for a pivot table.
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Changing the pivot table options
You can use the PivotTable Options dialog box (shown in Figure 2-14) to change 
the settings applied to any and all pivot tables that you create in a workbook. You 
open this dialog box by clicking the PivotTable command button on the PivotTable 
Tools tab’s Analyze tab followed by the Options menu item on the Options drop-
down button or by simply pressing Alt+JTTT.

The PivotTable Options dialog box contains the following six tabs:

»» Layout & Format with options for controlling the various aspects of the 
layout and formatting of the cells in the pivot table

»» Totals & Filters with options for controlling the display of the subtotals and 
grand totals in the report, and filtering and sorting the table’s fields

»» Display with options for controlling the display items in the table and the 
sorting of the fields in the PivotTable

»» Printing with options for controlling print expand and collapse buttons when 
displayed in the pivot table, and print titles with the row and column labels on 
each page of the printout

FIGURE 2-14:  
Modifying the 

pivot table 
options in  

the PivotTable 
Options 

dialog box.
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»» Data with options for controlling how the data that supports the pivot table is 
stored and refreshed

»» Alt Text with options for adding alternate, text-based titles and descriptions 
of the information in the pivot table for those with vision impairments who 
then hear the title and description read aloud

Perhaps the most important pivot table option is the Classic PivotTable Layout 
(Enables Dragging of Fields in the Grid) check box option on the Display tab. When 
you select this check box, Excel lets you rearrange the fields within the pivot table 
simply by dragging their icons onto the desired part of the table (Table Filter, 
Column Labels, or Row Labels). The program also lets you add fields to the pivot 
table by dragging them from the field list in the PivotTable Fields task pane and 
dropping them on the part of the table to which they are to be added.

Creating Pivot Charts
Instead of generating just a plain old boring pivot table, you can spice up your data 
summaries quite a bit by generating a pivot chart to go along with a supporting 
pivot table. To create a pivot chart from your pivot table, simply follow these two 
steps:

1.	 Click the PivotChart command button in the Tools group on the Analyze 
tab under the PivotTable Tools contextual tab or press Alt+JTC.

Excel opens the Insert Chart dialog box where you can select the type and 
subtype of the pivot chart you want to create. (See Book 5, Chapter 1.)

2.	 Click the thumbnail of the subtype of chart you want to create in the 
Insert Chart dialog box and then click OK.

As soon as you click OK after selecting the chart subtype, Excel inserts an embed-
ded pivot chart into the worksheet containing the original pivot table. This new 
pivot chart contains drop-down buttons for each of the four different types of 
fields used in the pivot chart (Report Filter, Legend Fields, Axis Fields, and Values). 
You can use these drop-down buttons to sort and filter the data represented in the 
chart. (See “Filtering a pivot chart” later in this chapter for details.)

In addition, Excel replaces the PivotTable Tools on the Ribbon with a PivotChart 
Tools contextual tab. This PivotChart Tools tab is then further subdivided into 
three tabs: Analyze, Design, and Format, which is automatically selected.
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Moving a pivot chart to its own sheet
Although Excel automatically creates all new pivot charts on the same worksheet 
as the pivot table, you may find customizing and working with the pivot chart 
easier if you move the chart to its own chart sheet in the workbook. To move a new 
pivot chart to its own chart sheet in the workbook, follow these steps:

1.	 Click the Analyze tab under the PivotChart Tools contextual tab to bring 
its tools to the Ribbon and then click the Move Chart command button or 
press Alt+JTV.

Excel opens the Move Chart dialog box.

2.	 Click the New Sheet option button in the Move Chart dialog box.

3.	 (Optional) Rename the generic Chart1 sheet name in the accompanying 
text box by entering a more descriptive name there.

4.	 Click OK to close the Move Chart dialog box and open the new chart sheet 
with your pivot chart.

Figure 2-15 shows a clustered column pivot chart after moving the chart to its 
own chart sheet in the workbook.

FIGURE 2-15:  
Clustered  

column pivot 
chart moved to  

its own Pivot 
Chart sheet.
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Filtering a pivot chart
When you graph the data in a pivot table using a typical chart type such as col-
umn, bar, or line that uses both an x- and y-axis, the Row labels in the pivot table 
appear along the x- or category-axis at the bottom of the chart and the Column 
labels in the pivot table become the data series that are delineated in the chart’s 
legend. The numbers in the Values field are represented on the y- or value-axis 
that goes up the left side of the chart.

When you generate a new pivot chart, Excel adds drop-down list buttons to each 
of the types of fields represented. You can then use these drop-down buttons in 
the pivot chart itself to filter the charted data represented in this fashion like you 
do the values in the pivot table. Remove the check mark from the (Select All) or 
(All) option and then add a check mark to each of the fields you still want repre-
sented in the filtered pivot chart.

Click the following drop-down buttons to filter a different part of the pivot chart:

»» Report Filter to filter which data series are represented in the pivot chart

»» Axis Fields (Categories) to filter the categories that are charted along the 
x-axis at the bottom of the chart

»» Legend Fields (Series) to filter the data series shown in columns, bars, or 
lines in the chart body and identified by the chart’s legend

Formatting a pivot chart
The command buttons on the Design and Format tabs attached to the PivotChart 
Tools contextual tab make it easy to further format and customize your pivot 
chart. Use the Design tab buttons to select a new chart style for your pivot chart or 
even a brand-new chart type and further refine your pivot chart by adding chart 
titles, text boxes, and gridlines. Use the Format tab’s buttons to refine the look of 
any graphics you’ve added to the chart as well as select a new background color 
for your chart.

To get specific information on using the buttons on these tabs, see Book 5, Chap-
ter 1, which covers creating charts from regular worksheet data. The Chart Tools 
contextual tab that appears when you select a chart you’ve created contains the 
same Design and Format tabs with comparable command buttons.
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